码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ】Crazy Search(hash)

时间:2018-04-22 21:54:52      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:一个   term   mod   out   对应关系   really   字母   NPU   orm   

Crazy Search

 
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5
题意:求一个字符串s(其中s的不同字符个数为nc)的所有长度为n的子串的数量 
思路:把原串中的每个字符给它赋值,用数字来代替不同的字母,比如a可以用0表示,b可以用1表示,等等。
   
然后再遍历长度为n的子串,把每个子串用刚才赋值的数字按nc进制转化成一个数(其实就是把长度为n的那一小段字符表示成一个数)。
   为什么要nc进制转换呢?因为不同的字符有nc个,转换成nc就是mod nc。
   只要子串不同,那表示出来的数字结果就一定不相同,这就把字符串和数字构成了一一对应关系,进而也就能用不同的数字表示不同的子串,最后只要遍历一下不同的数字有多少。

 

#include<iostream>
#include<cstring>
using namespace std;
int n,nc,sum,tot,ans,m[257];
char s[1000000];
bool hash[16000005];
int main()
{
    cin>>n>>nc>>s;
    for(int i=0;\0!=s[i];i++)
    {
        if(!m[s[i]])
        m[s[i]]=++tot;
        if(tot==nc) break;
    }
    int len=strlen(s);
    for(int i=0;i<=len-n;i++)
    {
        sum=0;
        for(int j=0;j<n;j++)
        sum=sum*nc+m[s[i+j]]-1;
        if(!hash[sum])
        hash[sum]=true,ans++;
    }
    cout<<ans;
    return 0;
}

 

【POJ】Crazy Search(hash)

标签:一个   term   mod   out   对应关系   really   字母   NPU   orm   

原文地址:https://www.cnblogs.com/Kohinur/p/8909091.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!