码迷,mamicode.com
首页 > 其他好文 > 详细

1005. Spell It Right(20)—PAT 甲级

时间:2018-04-29 22:17:27      阅读:262      评论:0      收藏:0      [点我收藏+]

标签:git   color   cut   表示   字符串输入   lin   一个   include   output   

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题目大意:求一个整数所有位上的数字之和,并用英文对应数字的每一位表示出来。
分析:因为N的位数高达100位,所以用字符串输入并遍历字符串得到所有数字的和,利用c++自带的to_string函数将和转化为整数类型,最后利用常量数组进行输出转换。

#include <iostream>
#include <string>
using namespace std;
const string num[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int main() {
    string str;
    int sum=0;
    cin>>str;
    for(auto c:str) {
        sum+=c-'0';
    }
    string s=to_string(sum);
    for(auto c:s) {
        if(c!=s.front()) cout<<" ";
        cout<<num[c-'0'];
    }
    cout<<endl;
    return 0;
}

1005. Spell It Right(20)—PAT 甲级

标签:git   color   cut   表示   字符串输入   lin   一个   include   output   

原文地址:https://www.cnblogs.com/Endlessp162096/p/8971861.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!