码迷,mamicode.com
首页 > 其他好文 > 详细

Period

时间:2018-05-02 20:56:41      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:前缀   namespace   period   after   std   ext   处理   ott   lse   

描述

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

输入

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) : the size of the string S.The second line contains the string S. The input file ends with a line, having the number zero on it.

输出

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

样例输入

3

aaa
12
aabaabaabaab
0

样例输出

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

解题思路:求出所给字符串前缀的循环子串  (只有当循环子串的数量大于1的时候才输出)

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define N 1000005
#define N 1000005
int next[N];
char s[N];
int slen;
void getNext()
{
    int j=0,k=-1;
    next[0] = -1;
    while(j < slen)
       {
            if(k == -1 || s[j] == s[k])
            next[++j] = ++k;
            else
            k = next[k];
       }
}  //KMP的数组处理
int main()
{
    int t=0;
    while(cin>>slen,slen!=0)
    {
        scanf("%s",s);
        cout<<"Test case #"<<++t<<endl;
        getNext();
        int l=1;
        for(int i=2;i<=slen;i++)
        {
            if(i%(i-next[i])==0)   //只有余数为0的时候才说明有循环子串
           {
                l=i/(i-next[i]);  //能分成最多的循环子串数量
                if(l!=1)
                cout<<i<<" "<<l<<endl;
           }
        }
        cout<<"\n";
    }

}

 

Period

标签:前缀   namespace   period   after   std   ext   处理   ott   lse   

原文地址:https://www.cnblogs.com/ww123/p/8981800.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!