码迷,mamicode.com
首页 > 其他好文 > 详细

Pat(Advanced Level)Practice--1016(Phone Bills)

时间:2014-05-13 06:45:05      阅读:460      评论:0      收藏:0      [点我收藏+]

标签:advance pat   基础题   map   

Pat1016代码

题目描述:

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers‘ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

AC代码:map的简单应用
#include<cstdio>
#include<iostream>
#include<string>
#include<map>
#include<vector>
#include<algorithm>

using namespace std;

typedef struct Calls
{
	int month;
	int day;
	int hour;
	int minute;
	string word;
}Calls;

bool cmp(const Calls &l,const Calls &r)
{
	if(l.day<r.day)
		return true;
	else if(l.day==r.day&&l.hour<r.hour)
		return true;
	else if(l.day==r.day&&l.hour==r.hour&&l.minute<r.minute)
		return true;
	else
		return false;
}

map<string,vector<Calls> > m;//存储名字对应的通话记录
int Rate[24];

float ComputeFee(Calls l,Calls r,int *totaltime)//计算通话费用
{
	float fee=0;
	*totaltime=0;
	while(l.day<r.day||l.hour<r.hour||l.minute<r.minute)
	{
		fee+=Rate[l.hour];
		(*totaltime)++;
		l.minute++;
		if(l.minute==60)
		{
			l.minute=0;
			l.hour++;
			if(l.hour==24)
			{
				l.hour=0;
				l.day++;
			}
		}
	}
	return fee;
}

int main(int argc,char *argv[])
{
	int i,j;
	int n;
	for(i=0;i<24;i++)
		cin>>Rate[i];
	cin>>n;
	for(i=0;i<n;i++)
	{
		string name;
		Calls temp;
		cin>>name;
		scanf("%d:%d:%d:%d",&temp.month,&temp.day,&temp.hour,&temp.minute);
		cin>>temp.word;
		m[name].push_back(temp);
	}
	map<string,vector<Calls> >::iterator it;
	vector<Calls>::iterator p;
	for(it=m.begin();it!=m.end();it++)
	{
		sort((it->second).begin(),(it->second).end(),cmp);
	}
	for(it=m.begin();it!=m.end();it++)
	{
		int FindPair=false;
		int totaltime=0;
		float total=0;
		for(p=(it->second).begin();p!=(it->second).end();p++)
		{                     //扫描通话记录,查看是否有符合条件的一对记录
			Calls temp=*p;
			if(temp.word[1]==‘n‘)
			{
				if((p+1)!=(it->second).end())
				{
					Calls next=*(p+1);
					if(next.word[1]==‘f‘)
					{
						if(!FindPair)
						{
							cout<<it->first;
							printf(" %02d\n",p->month);
							FindPair=true;
						}
		            printf("%02d:%02d:%02d %02d:%02d:%02d",temp.day,
					temp.hour,temp.minute,next.day,next.hour,next.minute);
                    float fee=ComputeFee(temp,next,&totaltime);
					printf(" %d $%.2f\n",totaltime,fee/100);
					total+=fee;
					}
				}
			}
		}
		if(FindPair)
	    	printf("Total amount: $%.2f\n",total/100);
	}

	return 0;
}

Pat(Advanced Level)Practice--1016(Phone Bills),布布扣,bubuko.com

Pat(Advanced Level)Practice--1016(Phone Bills)

标签:advance pat   基础题   map   

原文地址:http://blog.csdn.net/cstopcoder/article/details/25559285

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!