码迷,mamicode.com
首页 > 其他好文 > 详细

【TOJ-3369】CD

时间:2018-05-05 20:46:32      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:size   either   ini   font   family   sts   name   ber   time   

描述

Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.

输入

The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.

输出

For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.

样例输入

3 3
1
2
3
1
2
4
0 0

样例输出

2

#include<cstring>
#include<cstdio>
using namespace std;
int a[1000005],n;
int ok(int x)
{
    int bot=1;
    int top=n;
    int mid;
    while(bot<=top)
    {
        mid=(bot+top)/2;
        if(x<a[mid])
            top=mid-1;
        else if(x>a[mid])
            bot=mid+1;
        else
        return 1;
    }
    return 0;
}
int main()
{
    int m,i,x,s;
    while(scanf("%d%d",&n,&m),m||n)
    {
        memset(a,0,sizeof(a));
        s=0;
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(i=1;i<=m;i++)
        {
            scanf("%d",&x);
            s=s+ok(x);
        }
        printf("%d\n",s);
    }
    return 0;
}

 

【TOJ-3369】CD

标签:size   either   ini   font   family   sts   name   ber   time   

原文地址:https://www.cnblogs.com/kannyi/p/8995649.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!