码迷,mamicode.com
首页 > 其他好文 > 详细

CD(二分)

时间:2018-05-05 21:47:38      阅读:306      评论:0      收藏:0      [点我收藏+]

标签:ast   roo   process   \n   case   clear   sample   思想   positive   

Problem Description

Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.

Input

The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.

Output

For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.

Sample Input

3 3
1
2
3
1
2
4
0 0

Sample Output

 2

虽然二分的思想小学就接触到到了,但是没想到查找居然这么快(emmm)

下面是自己脑补的算法,卡时间过去了,之前卡了十几次

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<vector>
using namespace std;
vector<long long> a;
vector<long long>::iterator i,j;
int main()
{
    int n,m;
    long long z;
    while(scanf("%d%d",&n,&m),n,m)
    {
        a.clear();
        int M=0;
        while(n--)
        {
            scanf("%I64d",&z);
            a.push_back(z);
        }
        while(m--)
        {
            scanf("%d",&z);
            a.push_back(z);
        }
        sort(a.begin(),a.end());
        i=a.begin();
        j=i++;
        for(;i!=a.end();i++,j++)
        {
            if(*i==*j) M++;
        }
        printf("%d\n",M);
    }
}

下面是二分的算法

#include<stdio.h>
int a[1000001];
int main()
{
    int n,m,f,l,i,mid,z,M;
    while(scanf("%d%d",&n,&m),n,m)
    {
        M=0;
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        while(m--)
        {
            scanf("%d",&z);
            f=0;
            l=n-1;
            while(1)
            {
                mid=(f+l)/2;
                if(z>a[mid]) f=mid+1;
                else if(z<a[mid]) l=mid-1;
                else
                {
                    M++;
                    break;
                }
                if(f>l) break;
            }
        }
        printf("%d\n",M);
    }
}

 

CD(二分)

标签:ast   roo   process   \n   case   clear   sample   思想   positive   

原文地址:https://www.cnblogs.com/mayouyou/p/8996182.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!