码迷,mamicode.com
首页 > 其他好文 > 详细

【1004】(bfs)

时间:2018-05-06 16:17:18      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:geo   replace   can   bfs   position   pos   cap   trap   gen   

描述

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

输入

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#‘ and empty cells are represented by a ‘.‘. Your starting position is indicated by ‘S‘ and the exit by the letter ‘E‘. There‘s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

输出

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped! 

样例输入

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

样例输出

Escaped in 11 minute(s).
Trapped!

#include<bits/stdc++.h>
using namespace std;
char G[35][35][35];
int h,r,c,minn;
struct node{
    int x,y,z,s;
}a;
void bfs(int i,int j,int k,int s)
{
    queue<node>qu;
    qu.push(node{i,j,k,0});
    while(!qu.empty())
    {
        a=qu.front();
        qu.pop();
        if(a.x>=1&&a.y>=1&&a.z>=1&&a.x<=h&&a.y<=r&&a.z<=c&&G[a.x][a.y][a.z]!=#)
        {
            qu.push(node{a.x+1,a.y,a.z,a.s+1});
            qu.push(node{a.x-1,a.y,a.z,a.s+1});
            qu.push(node{a.x,a.y+1,a.z,a.s+1});
            qu.push(node{a.x,a.y-1,a.z,a.s+1});
            qu.push(node{a.x,a.y,a.z+1,a.s+1});
            qu.push(node{a.x,a.y,a.z-1,a.s+1});
        }
        if(G[a.x][a.y][a.z]==E)
        {
            minn=a.s;
            return;
        }
        G[a.x][a.y][a.z]=#;
    }
    return;
}
int main()
{
    int i,j,k,flag;
    while(scanf("%d%d%d",&h,&r,&c)!=EOF,h||r||c)
    {
        minn=99999999;
        flag=0;
        for(i=1;i<=h;i++)
            for(j=1;j<=r;j++)
                scanf("%s",G[i][j]+1);
                
        for(i=1;i<=h;i++)
            for(j=1;j<=r;j++)
                for(k=1;k<=c;k++)
                    if(G[i][j][k]==S)
                    {
                        bfs(i,j,k,0);
                        flag=1;
                        break;
                    }

        if(minn==99999999)
            printf("Trapped!\n");
        else 
            printf("Escaped in %d minute(s).\n",minn);
    }
    return 0;
}

 

【1004】(bfs)

标签:geo   replace   can   bfs   position   pos   cap   trap   gen   

原文地址:https://www.cnblogs.com/kannyi/p/8998317.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!