码迷,mamicode.com
首页 > 其他好文 > 详细

1015. Reversible Primes (20) ——PAT (Advanced Level) Practise

时间:2014-09-25 23:31:28      阅读:286      评论:0      收藏:0      [点我收藏+]

标签:1015   reversible primes   pat   advanced level   practice   

题目信息:

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No


代码如下:

#include <stdio.h>
#include <math.h>
int is_prime(int n) //素数判断
{
	if (1 == n)
		return 0;
	int end = sqrt((double)n);
	for (int i = 2; i <= end; ++i)
	{
		if (n%i == 0)
			return 0;
	}
	return 1;
}
int re(int a, int radix) //按radix进制反转
{
	int arr[20], loc = 0, s = 0, base = 1;
	while (a)
	{
		arr[loc++] = a % radix;
		a /= radix;
	}
	while (loc--)
	{
		s += arr[loc] * base;
		base *= radix;
	}
	return s;
}
int main()
{
	int a, b;
	while (scanf("%d", &a) && a > 0)
	{
		scanf("%d", &b);
		if (is_prime(a) && is_prime(re(a, b)))
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}



1015. Reversible Primes (20) ——PAT (Advanced Level) Practise

标签:1015   reversible primes   pat   advanced level   practice   

原文地址:http://blog.csdn.net/xianyun2009/article/details/39557945

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!