码迷,mamicode.com
首页 > 其他好文 > 详细

fzu2147_A-B Game

时间:2018-05-12 15:08:05      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:des   contains   clu   ext   最大   long   AC   sample   game   

Problem Description
Fat brother and Maze are playing a kind of special (hentai) game by two integers A and B. First Fat brother write an integer A on a white paper and then Maze start to change this integer. Every time Maze can select an integer x between 1 and A-1 then change A into A-(A%x). The game ends when this integer is less than or equals to B. Here is the problem, at least how many times Maze needs to perform to end this special (hentai) game.

 Input
The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case contains two integers A and B described above.
1 <= T <=100, 2 <= B < A < 100861008610086

 Output
For each case, output the case number first, and then output an integer describes the number of times Maze needs to perform. See the sample input and output for more details.

 Sample Input
2
5 3
10086 110
 Sample Output
Case 1: 1
Case 2: 7

A=A-(A%x),A要最小,则A%x要最大,这个最大是x-1,此时x=(A+1)/2,当A为奇数时把A变成(A+1)/2,偶数变为A/2+1,直到A<=B
注意用long long来存A B
***

#include <iostream>

using namespace std;

int main()
{
    int t;
    cin>>t;
    for(int i=1;i<=t;++i)
    {
        long long a,b;
        cin>>a>>b;
        int num=0;
        while(a>b)
        {
            ++num;
            if(a%2)
                a=(a+1)/2;
            else
                a=a/2+1;
        }
        cout<<"Case "<<i<<": "<<num<<endl;
    }
    return 0;
}

fzu2147_A-B Game

标签:des   contains   clu   ext   最大   long   AC   sample   game   

原文地址:https://www.cnblogs.com/nmkazu/p/9028629.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!