码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3371 Connect the Cities

时间:2014-09-26 23:38:58      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   for   sp   div   

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
1

题意:给你n m k; 最小生成树的经典输入,k的意思代表给定有k条路已经连通了。现在要你求出连通所有路的最小价值

思路:最小生成树的变形,只要用并查集把已经连通的点放到一起就可以了,再最小生成树算法

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,cnt;
int f[520];
int flag[520];
#define N 25005
struct node
{
    int u,v,w;
}num[N];

bool cmp(node x,node y)
{
    return x.w<y.w;
}

int find(int x)
{
    if(x!=f[x])
        f[x]=find(f[x]);
    return f[x];
}

int kruscal()
{
    int x,y,i;
    //int dian=n;
    int sum=0;
    for(i=0;i<cnt;i++)
    {
        x=find(num[i].u);
        y=find(num[i].v);
        if(x==y)
            continue;
        sum+=num[i].w;
        f[x]=y;
        flag[num[i].u]=1;
        flag[num[i].v]=1;
      /*  dian--;
        if(dian==0)
            break;*/
    }
  /*  if(i==cnt)
        return -1;*/
 //   else
        return sum;
}
int main()
{
    int k,i,j,sum;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        cnt=0;
        scanf("%d %d %d",&n,&m,&k);
        memset(flag,0,sizeof(int)*(n+2));
        for(i=0;i<=n;i++)
            f[i]=i;
        for(i=0;i<m;i++)
        {
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            num[cnt].u=a;
            num[cnt].v=b;
            num[cnt++].w=c;

        }
        sort(num,num+cnt,cmp);
        for(i=0;i<k;i++)
        {
            int a,b;
            int test;
            scanf("%d",&test);
            scanf("%d",&a);
            flag[a]=1;
            for(j=1;j<test;j++)
            {
                scanf("%d",&b);
                flag[b]=1;
                int x=find(a);
                int y=find(b);
                if(x!=y)
                    f[x]=y;
            }
        }
        sum=kruscal();
        for(i=1;i<=n;i++)
            if(!flag[i])
                break;
        if(i<=n)
            printf("-1\n");
        else
            printf("%d\n",sum);
    }
    return 0;
}


HDU 3371 Connect the Cities

标签:des   style   color   io   os   ar   for   sp   div   

原文地址:http://blog.csdn.net/u012313382/article/details/39584649

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!