码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ-a letter and a number

时间:2014-09-27 10:42:09      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   color   io   os   ar   strong   for   

a letter and a number
时间限制:3000 ms  |  内存限制:65535 KB
难度:1
描述
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4
代码:
  1. #include<stdio.h>  
  2. int main() 
  3.     int t,y; 
  4.     char ch; 
  5.     scanf("%d",&t); 
  6.     while(t--) 
  7.     { 
  8.         getchar();  //注意字符输入时可能出现的问题,否则ch可能会接收‘\n‘; 
  9.         scanf("%c%d",&ch,&y); 
  10.         if(ch>=‘a‘&&ch<=‘z‘
  11.         printf("%d\n",y-(ch-‘a‘+1)); 
  12.         else 
  13.         printf("%d\n",y+(ch-‘A‘+1)); 
  14.     } 
  15.     return 0

NYOJ-a letter and a number

标签:style   blog   http   color   io   os   ar   strong   for   

原文地址:http://blog.csdn.net/weitao1234/article/details/39604973

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!