码迷,mamicode.com
首页 > 其他好文 > 详细

1011 A+B和C (15)(15 分)

时间:2018-05-29 22:51:07      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:a+b   algorithm   style   title   als   str   define   个数   ace   

1011 A+B和C (15)(15 分)

给定区间[-2^31^, 2^31^]内的3个整数A、B和C,请判断A+B是否大于C。

输入格式:

输入第1行给出正整数T(<=10),是测试用例的个数。随后给出T组测试用例,每组占一行,顺序给出A、B和C。整数间以空格分隔。

输出格式:

对每组测试用例,在一行中输出“Case #X: true”如果A+B>C,否则输出“Case #X: false”,其中X是测试用例的编号(从1开始)。

输入样例:

4
1 2 3
2 3 4
2147483647 0 2147483646
0 -2147483648 -2147483647

输出样例:

Case #1: false
Case #2: true
Case #3: true
Case #4: false
#include <iostream>
#include <algorithm>

using namespace std ; 

#define LL long long
LL a , b , c ; 

int main(){

    int t ; 
    cin >> t ; 
    for(int i=1 ; i<=t ; i++){
        cin >> a >> b >> c ; 
        if(a+b>c){
            cout << "Case #" << i << ": true" << endl ; 
        }else{
            cout << "Case #" << i << ": false" << endl ;
        }
    }

}

 

1011 A+B和C (15)(15 分)

标签:a+b   algorithm   style   title   als   str   define   个数   ace   

原文地址:https://www.cnblogs.com/yi-ye-zhi-qiu/p/9108008.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!