码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5053 the Sum of Cube(数学求立方和)

时间:2014-09-27 23:56:50      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:数学   hdu   立方和   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5053


Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.
 
Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].
 
Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.
 
Sample Input
2 1 3 2 5
 
Sample Output
Case #1: 36 Case #2: 224
 
Source


代码如下:

#include <cstdio>
#include <cmath>
int main()
{
    __int64 a,b,sum;
    int t;
    int cas = 0;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            sum = 0;
            scanf("%I64d%I64d",&a,&b);
            for(__int64 i = a; i <= b; i++)
            {
                sum+=i*i*i;
            }
            printf("Case #%d: %I64d\n",++cas,sum);
        }
    }
    return 0;
}



HDU 5053 the Sum of Cube(数学求立方和)

标签:数学   hdu   立方和   

原文地址:http://blog.csdn.net/u012860063/article/details/39618007

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!