码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 5053 the Sum of Cube

时间:2014-09-28 01:35:40      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.
 

Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.
 

Sample Input
2 1 3 2 5
 

Sample Output
Case #1: 36 Case #2: 224
 

Source
 

题意:不算难的题

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef __int64 ll;
using namespace std;

int main() {
    int t, a, b, cas =1 ;
    scanf("%d", &t);
    while (t--) {
        scanf("%d%d", &a, &b);    
        ll sum = 0;
        for (int i = a; i <= b; i++)
            sum += (ll)i * i * i;
        printf("Case #%d: ", cas++);
        printf("%I64d\n", sum);
    }
    return 0;
}




HDU - 5053 the Sum of Cube

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://blog.csdn.net/u011345136/article/details/39620381

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!