码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1025 LIS二分优化

时间:2018-06-03 12:32:40      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:recommend   main   orm   递增   个性   because   def   blank   panel   

题目链接:

acm.hdu.edu.cn/showproblem.php?pid=1025

Constructing Roads In JGShining‘s Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28755    Accepted Submission(s): 8149


Problem Description
JGShining‘s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they‘re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don‘t wanna build a road with other poor ones, and rich ones also can‘t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

技术分享图片


In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what‘s the maximal number of road(s) can be built.
 

 

Sample Input
2
1 2
2 1
3
1 2
2 3
3 1
 

 

Sample Output
Case 1:
My king, at most 1 road can be built.
 
Case 2:
My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.
 
题目大意:
两排城市,要把标号相同的连接起来,但是不能交叉,问至少连几根线
 
LIS问题,不过要优化
#include<bits/stdc++.h>
#define max_v 500005
using namespace std;
int a[max_v],dp[max_v],len;
int main()
{
    int n,c=1;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            a[x]=y;
        }
        //dp[k]代表长度为k的LIS序列的最末元素,
        //若有多个长度为k的上升子序列,
        //则记录最小的那个最末元素
        //dp[]中的元素是单调递增的,
        //二分优化的时候利用这个性质

        dp[1]=a[1];
        len=1;
        for(int i=2; i<=n; i++)
        {
            if(a[i]>dp[len])
            {
                dp[++len]=a[i];
            }
            else
            {
               int j=lower_bound(dp,dp+len,a[i])-dp;
                dp[j]=a[i];
            }
        }
        if(len==1)
        {
            printf("Case %d:\nMy king, at most %d road can be built.\n\n",c++,len);
        }else
        {
            printf("Case %d:\nMy king, at most %d roads can be built.\n\n",c++,len);
        }
    }
    return 0;
}

 

HDU 1025 LIS二分优化

标签:recommend   main   orm   递增   个性   because   def   blank   panel   

原文地址:https://www.cnblogs.com/yinbiao/p/9128222.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!