码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5053 the Sum of Cube(上海网络赛)

时间:2014-09-28 18:03:45      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:algorithm

the Sum of Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 405    Accepted Submission(s): 224


Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.
 

Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.
 

Sample Input
2 1 3 2 5
 

Sample Output
Case #1: 36 Case #2: 224
 

Source
 


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int main()
{
    long long a,b;
    int ca=1;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d",&a,&b);
        printf("Case #%d: %I64d\n",ca++,(b*(b+1)/2)*(b*(b+1)/2)-(a*(a-1)/2)*(a*(a-1)/2));
    }
    return 0;
}

hdu 5053 the Sum of Cube(上海网络赛)

标签:algorithm

原文地址:http://blog.csdn.net/caduca/article/details/39643589

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!