码迷,mamicode.com
首页 > 其他好文 > 详细

DP———2.最大m子序列和

时间:2018-06-09 19:42:40      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:stream   describe   names   pac   ted   AMM   lap   task   AC   

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35485    Accepted Submission(s): 12639


Problem Description
Now I think you have got an AC in Ignatius.L‘s "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don‘t want to write a special-judge module, so you don‘t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

 

Output
Output the maximal summation described above in one line.
 

 

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

 

Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 
状态dp[i][j]有前j个数,组成i组的和的最大值。决策: 
第j个数,是在第包含在第i组里面,还是自己独立成组。
方程 dp[i][j]=Max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j
空间复杂度,m未知,n<=1000000, 继续滚动数组。
时间复杂度 n^3. n<=1000000. 显然会超时,继续优化。
max( dp[i-1][k] ) 就是上一组 0....j-1 的最大值。
我们可以在每次计算dp[i][j]的时候记录下前j个的最大值
用数组保存下来 下次计算的时候可以用,这样时间复杂度为 n^2.

技术分享图片
#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
const int maxn = 1e6+10;
const int INF = 0x7fffffff;
int dp[maxn];
int a[maxn];
int mmax[maxn];
int main(){
    int n,m;
    int maxx;
    while(scanf("%d%d",&m,&n) !=EOF){
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            mmax[i]=0;
            dp[i]=0;
        }
        dp[0]=0;
        mmax[0]=0;
        for(int i=1;i<=m;i++){
            maxx=-1*INF;
            for(int j=i;j<=n;j++){
                dp[j]=max(dp[j-1]+a[j],mmax[j-1]+a[j]);
                mmax[j-1]=maxx;
                maxx=max(maxx,dp[j]);
            }
        }
        printf("%d\n", maxx);
    }
    return 0;
}
View Code

 

DP———2.最大m子序列和

标签:stream   describe   names   pac   ted   AMM   lap   task   AC   

原文地址:https://www.cnblogs.com/buerdepepeqi/p/9153161.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!