码迷,mamicode.com
首页 > 其他好文 > 详细

(compareTo) How Many Fibs hdu1316 && ZOJ1962

时间:2018-06-11 13:45:25      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:big   case   public   can   AC   several   斐波那契数列   equals   out   

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7007    Accepted Submission(s): 2761

 

 

Problem Description

Recall the definition of the Fibonacci numbers:

f1 := 1

f2 := 2

fn := fn-1 + fn-2 (n >= 3)

 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].

 

Input

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.

 

Output

For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.

 

Sample Input

10 100

1234567890 9876543210

0 0

 

Sample Output

5

4

用Java,然后利用compareTo来判断大小。

 

 

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        BigInteger a,b;
        while(in.hasNextBigInteger()) {
            a=in.nextBigInteger();
            b=in.nextBigInteger();
            if(a.equals(BigInteger.valueOf(0))&&b.equals(BigInteger.valueOf(0)))
                break;                 //也可以用compareTo。
            System.out.println(Fib(a,b));
        }
    }
     public static int Fib(BigInteger a,BigInteger b)  
        {  
            int sum = 0;  
            BigInteger f = new BigInteger("1");  
            BigInteger s = new BigInteger("2");  
            BigInteger tmp;  
            while(true)  
            {  
                if(f.compareTo(b)>0)  
                    break;  
                if(f.compareTo(a) >= 0)  
                    sum++;  
                tmp = f;                      //可以用迭代的方法求斐波那契数列。
                f = s;  
                s = s.add(tmp);  
            }  
            return sum;  
        }  
}

 

(compareTo) How Many Fibs hdu1316 && ZOJ1962

标签:big   case   public   can   AC   several   斐波那契数列   equals   out   

原文地址:https://www.cnblogs.com/Weixu-Liu/p/9166478.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!