码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3723 Conscription

时间:2018-06-11 23:34:16      阅读:225      评论:0      收藏:0      [点我收藏+]

标签:cstring   arch   poj   country   monthly   sed   without   his   line   

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

 
最小生成树,Kruskall算法。
代码:
技术分享图片
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
struct rela {
    int x,y,d;
}s[50000];
int t,n,m,r;
int f[20000];
void init() {
    for(int i = 0;i < (n + m);i ++) {
        f[i] = i;
    }
}
int getf(int x) {
    if(x != f[x])f[x] = getf(f[x]);
    return f[x];
}
int mer(int x,int y) {
    int xx = getf(x);
    int yy = getf(y);
    if(xx == yy)return 1;
    f[xx] = yy;
    return 0;
}
bool cmp(rela a,rela b) {
    return a.d > b.d;
}
int main() {
    scanf("%d",&t);
    while(t --) {
        scanf("%d%d%d",&n,&m,&r);
        int ans = (n + m) * 10000;
        init();
        for(int i = 0;i < r;i ++) {
            scanf("%d%d%d",&s[i].x,&s[i].y,&s[i].d);
            s[i].y += n;
        }
        sort(s,s + r,cmp);
        for(int i = 0;i < r;i ++) {
            if(mer(s[i].x,s[i].y))continue;
            ans -= s[i].d;
        }
        printf("%d\n",ans);
    }
}
View Code

 

poj 3723 Conscription

标签:cstring   arch   poj   country   monthly   sed   without   his   line   

原文地址:https://www.cnblogs.com/8023spz/p/9170423.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!