码迷,mamicode.com
首页 > 其他好文 > 详细

Bone Collector(01背包)

时间:2018-06-15 22:37:54      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:for   eof   Collector   algorithm   ring   cow   different   name   AC   

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 
技术分享图片

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14
题目大意:
给定n,v分别代表n个骨头,体积为v的背包,接下来n个数字代表n个骨头的价值,再接下来n个数字代表n个骨头的体积。
01背包模板
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int w[1005],v[1005],dp[1005];
int n,m;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(dp,0,sizeof dp);
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            cin>>v[i];
        for(int i=1;i<=n;i++)
            cin>>w[i];
        for(int i=1;i<=n;i++)
            for(int j=m;j>=w[i];j--)
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        cout<<dp[m]<<\n;
    }
    return 0;
}

 

 

Bone Collector(01背包)

标签:for   eof   Collector   algorithm   ring   cow   different   name   AC   

原文地址:https://www.cnblogs.com/zdragon1104/p/9189020.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!