标签:0ms begin include desc job its pread initial file
题目:
Time Limit: 1000MS |
|
Memory Limit: 20000K |
Total Submissions: 48312 |
|
Accepted: 23113 |
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are
many student groups. Students in the same group intercommunicate with
each other frequently, and a student may join several groups. To prevent
the possible transmissions of SARS, the NSYSU collects the member lists
of all student groups, and makes the following rule in their standard
operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects
when a student is recognized as a suspect. Your job is to write a
program which finds all the suspects.
Input
The
input file contains several cases. Each test case begins with two
integers n and m in a line, where n is the number of students, and m is
the number of groups. You may assume that 0 < n <= 30000 and 0
<= m <= 500. Every student is numbered by a unique integer between
0 and n?1, and initially student 0 is recognized as a suspect in all
the cases. This line is followed by m member lists of the groups, one
line per group. Each line begins with an integer k by itself
representing the number of members in the group. Following the number of
members, there are k integers representing the students in this group.
All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
思路:
代码:
#include <iostream>
int Find(int a[], int x)//递归的路径压缩
{
if(x == a[x])
return x;
return a[x] = Find(a,a[x]);
}
bool IsConnected(int a[], int x, int y)
{
return Find(a,x) == Find(a,y);
}
void Union(int a[], int b[], int x, int y)
{
int c = Find(a,x);
int d = Find(a,y);
a[c] = d;
b[d] += b[c];
return;
}
int main(void)
{
using namespace std;
int n, m;
while(cin >> n >> m && (n != 0 || m != 0))
{
int * a = new int[n];
int * b = new int[n];
for(int i = 0; i < n; i++)
{
a[i] = i;
b[i] = 1;
}
while(m--)//m行
{
int line;
cin >> line;
int * group = new int[line];
for(int i = 0; i < line; i++)//输入一行数据到数组group中
cin >> group[i];
for(int i = 1; i < line; i++)
{
if(IsConnected(a,group[0],group[i]))
continue;
Union(a,b,group[0],group[i]);
}
delete[] group;
}
int ans = b[Find(a,0)];
printf("%d\n", ans);
delete[] a;
delete[] b;
}
return 0;
}
The Suspects//并查集
标签:0ms begin include desc job its pread initial file
原文地址:https://www.cnblogs.com/w-j-c/p/9218935.html