码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2026 首字母变大写

时间:2018-06-24 22:32:24      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:sam   script   std   while   字母   包含   show   ott   its   

http://acm.hdu.edu.cn/showproblem.php?pid=2026

 

Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 
Output
请输出按照要求改写后的英文句子。
 
Sample Input
i like acm
i want to get an accepted
 
Sample Output
I Like Acm
I Want To Get An Accepted
 
代码:
#include <bits/stdc++.h>

using namespace std;

char s[111];

int main()
{
    while(gets(s))
    {
        int len = strlen(s);
        if(s[0]>=‘a‘&&s[0]<=‘z‘)
            s[0]=s[0]-32;
        for(int i=0; i<len; i++)
        {
            if(s[i]==‘ ‘)
                s[i+1]-=32;
        }
        for(int i=0; i<len; i++)
        {
            printf("%c",s[i]);
        }
        cout<<endl;
    }
    return 0;
}

  

HDU 2026 首字母变大写

标签:sam   script   std   while   字母   包含   show   ott   its   

原文地址:https://www.cnblogs.com/zlrrrr/p/9221866.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!