码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5056 Boring count(数学)

时间:2014-09-29 22:52:01      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:数学   hdu   bestcoder   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5056


Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
 
Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
 
Output
For each case, output a line contains the answer.
 
Sample Input
3 abc 1 abcabc 1 abcabc 2
 
Sample Output
6 15 21
 
Source


官方题解:
bubuko.com,布布扣

代码如下:
#include <cstdio>
#include <cstring>
const int maxn = 100017;
int main()
{
    int t;
    char str[maxn];
    int st[27];
    int k;
    scanf("%d",&t);
    while(t--)
    {
        memset(st,0,sizeof(st));
        scanf("%s",str);
        scanf("%d",&k);
        __int64 ans = 0;
        int len = strlen(str);
        int startpos = 0;
        for(int i = 0; i < len; i++)
        {
            int tt = str[i] -'a';
            st[tt]++;
            if(st[tt] > k)
            {
                while(str[startpos]!=str[i])
                {
                    st[str[startpos]-'a']--;
                    startpos++;
                }
                st[str[startpos]-'a']--;
                startpos++;
            }
            ans+=i-startpos+1;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}



HDU 5056 Boring count(数学)

标签:数学   hdu   bestcoder   

原文地址:http://blog.csdn.net/u012860063/article/details/39674597

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!