码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4800 Josephina and RPG

时间:2014-09-30 01:23:31      阅读:317      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   io   os   ar   java   strong   

Josephina and RPG

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 605    Accepted Submission(s): 165
Special Judge


Problem Description
A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.
Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.
The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team gets victory only if they beat all the AI teams.
Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?
 

 

Input
There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.
 

 

Output
For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.
 

 

Sample Input
4
0.50 0.50 0.20 0.30
0.50 0.50 0.90 0.40
0.80 0.10 0.50 0.60
0.70 0.60 0.40 0.50
3
0 1 2
 

 

Sample Output
0.378000
 

 

这条题给一个忽悠你的m 。。

然后搞一个 C (3 ,m)*C(3 , m )的矩阵 , 然后开始DP 

主要的是,一个队赢了另一个队的话可以用那个队取缔打下一场,或者继续选择现在的队伍。 

然后用一个 dp[i][j]  ..表示用队伍 j 刷到第 i 个AI 队 的最大概率, 然后就开始转移了 。

不过写的比较烂~ 

 

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
#define eps 1e-6
double dp[10010][121] , p[122][122];
long long f[12];
int x[10010];
int n , m ;
long long r;

void init()
{
    for( int i = 0 ; i <= n ; ++i ){
        for( int j = 0 ; j <= r ; ++j ){
                dp[i][j] = 0.0 ;
            }
        }
        for( int i = 0 ; i < r ; ++i ){
            dp[1][i] = max ( dp[1][i] ,  p[ i ][ x[1] ] ) ;
            dp[1][ x[1] ] = max( dp[1][ x[1] ] , dp[1][i] );
        }
}

int main()
{

    ios::sync_with_stdio(0);
    f[0] = 1;
    for( int i = 1 ; i < 11 ; ++i ){ f[i] = i * f[i-1] ; }

//    freopen("in","r",stdin);

    while( ~scanf("%d",&m) ){

        r = f[m] /  f[3] / f[m-3] ;

        for( int i = 0 ; i < r ; ++i ){
            for( int j = 0 ; j < r ;++j ){
                scanf("%lf",&p[i][j]) ;
            }
        }

        scanf("%d",&n );
        for( int i = 1 ; i <= n ;++i ){
            scanf("%d",&x[i]);
        }
        init();

        for(int i = 2 ; i <= n  ; ++i ){
            for( int j = 0 ; j < r ; ++j ){
                dp[ i ] [ x[i] ]= max( dp[ i ][ x[i] ] , dp[ i - 1 ][ j ] * p[ j ][ x[i] ]  );
                dp[ i ] [ j ] = max ( dp[ i ][ j ] , dp[ i - 1 ][ j ] * p[ j ][ x[i] ]  );
            }
        }

        double ans = 0.0 ;
        for( int j = 0; j < r ; ++j ){
            ans = max( ans , dp[n][j] );
        }
        printf("%.6lf\n", ans );
    }
    return 0;
}

 

HDU 4800 Josephina and RPG

标签:des   style   blog   color   io   os   ar   java   strong   

原文地址:http://www.cnblogs.com/YRETSIM/p/4001044.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!