码迷,mamicode.com
首页 > 其他好文 > 详细

Median Weight Bead(最短路—floyed传递闭包)

时间:2018-06-29 22:23:43      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:闭包   data   sample   rip   ++   说明   cond   ram   file   

Description

There are N beads which of the same shape and size, but with different weights. N is an odd number and the beads are labeled as 1, 2, ..., N. Your task is to find the bead whose weight is median (the ((N+1)/2)th among all beads). The following comparison has been performed on some pairs of beads: 
A scale is given to compare the weights of beads. We can determine which one is heavier than the other between two beads. As the result, we now know that some beads are heavier than others. We are going to remove some beads which cannot have the medium weight. 

For example, the following results show which bead is heavier after M comparisons where M=4 and N=5. 
1.	Bead 2 is heavier than Bead 1.

2. Bead 4 is heavier than Bead 3.
3. Bead 5 is heavier than Bead 1.
4. Bead 4 is heavier than Bead 2.

From the above results, though we cannot determine exactly which is the median bead, we know that Bead 1 and Bead 4 can never have the median weight: Beads 2, 4, 5 are heavier than Bead 1, and Beads 1, 2, 3 are lighter than Bead 4. Therefore, we can remove these two beads. 

Write a program to count the number of beads which cannot have the median weight. 

Input

The first line of the input file contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of input data contains an integer N (1 <= N <= 99) denoting the number of beads, and M denoting the number of pairs of beads compared. In each of the next M lines, two numbers are given where the first bead is heavier than the second bead. 

Output

There should be one line per test case. Print the number of beads which can never have the medium weight.

Sample Input

1
5 4
2 1
4 3
5 1
4 2

Sample Output

2

题目意思:对于T组输入输出,有n个珍珠(n为奇数),有m次称重机会,排列在前面编号的珍珠比后面的珍珠要重,求出能判断出有多少个珍珠的重量一定不
是中间值。

解题思路:在这里我们需要想明白的是要找的这个中间数,一定是重量要大于个数一半珍珠的重量或者是重量要小于个数一半珍珠的重量。
同时也要明白如果大于(小于)了一半的个数,一定不同时存在小于(大于)一半的个数。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int map[200][200];
int floyd()
{
    int i,j,k;
    for(k=1; k<=n; k++)
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                if(map[i][k]&&map[k][j])
                {
                    map[i][j]=1;///如果任意两个点能够通过第三个点发生关系,那么说明这两个点也是有关系的
                }
            }
}
int main()
{
    int a,b,i,j,count,sum1,sum2,t,flag;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        flag=n/2;
        for(i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            map[a][b]=1;///可以确定关系的利用邻接矩阵记录为1
        }
        floyd();
        count=0;
        for(i=1; i<=n; i++)
        {
            sum1=0;
            sum2=0;
            for(j=1; j<=n; j++)
            {
                if(map[i][j])///利用该矩阵求出比该点大的点
                {
                    sum1++;
                }
                if(map[j][i])///利用该矩阵求出比该点小的点
                {
                    sum2++;
                }

            }
            if(sum1>flag)///比该点大的点数超过了1/2,则这个点一定不是中值点
            {
                count++;
            }
            if(sum2>flag)///比该点小的点数超过了1/2,则这个点一定不是中值点
            {
                count++;
            }
        }
        printf("%d\n",count);
    }
    return 0;
}

  

 

  

 

Median Weight Bead(最短路—floyed传递闭包)

标签:闭包   data   sample   rip   ++   说明   cond   ram   file   

原文地址:https://www.cnblogs.com/wkfvawl/p/9245516.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!