码迷,mamicode.com
首页 > 其他好文 > 详细

hduoj 1004 Let the Balloon Rise [链表解法]

时间:2018-07-03 22:29:08      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:sed   str   结构   multi   malloc   input   lower   sizeof   class   

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1004


Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink


解题思路: 采用链表的数据结构

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct balloon
{
    char color[16];
    int sum;
    struct balloon *next;
};
int main()
{
    struct balloon *head,*p,*q;
    int n,maxSum;
    char color[16];
    while (~scanf("%d",&n) && n)
    {
        maxSum = -1;
        head = (struct balloon *) malloc(sizeof(struct balloon));
        head->sum = 0;
        head->next = NULL;
        getchar();
        while (n--)
        {
            gets(color);
            if (!strcmp(head->color,color))
            {
                if (!head->sum)
                    strcpy(head->color,color);
                head->sum++;
            }
            else if (strcmp(head->color,color) > 0)
            {
                p = head;
                head = (struct balloon *) malloc(sizeof(struct balloon));
                strcpy(head->color,color);
                head->sum = 1;
                head->next = p;
            }
            else
            {
                p = head;
                while (p->next && strcmp(p->next->color,color) < 0)
                    p = p->next;
                if (!p->next)
                {
                    q = (struct balloon *) malloc(sizeof(struct balloon));
                    strcpy(q->color,color);
                    q->sum = 1;
                    q->next = NULL;
                    p->next = q;
                }
                else if (strcmp(p->next->color,color) > 0)
                {
                    q = (struct balloon *) malloc(sizeof(struct balloon));
                    strcpy(q->color,color);
                    q->sum = 1;
                    q->next = p->next;
                    p->next = q;
                }
                else
                    p->next->sum++;
            }
        }
        p = head;
        while (p)
        {
            if (p->sum > maxSum)
            {
                maxSum = p->sum;
                strcpy(color,p->color);
            }
            p = p->next;
        }
        puts(color);
        while (p)
        {
            q = p->next;
            free(p);
            p = q;
        }
    }
    return 0;
}

hduoj 1004 Let the Balloon Rise [链表解法]

标签:sed   str   结构   multi   malloc   input   lower   sizeof   class   

原文地址:https://www.cnblogs.com/thoufer/p/9260779.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!