码迷,mamicode.com
首页 > 其他好文 > 详细

Multiply game HDU-3074

时间:2018-07-04 22:42:54      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:can   multi   its   hang   name   use   play   efi   pos   

Multiply game

 

Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence. 
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he… 

InputThe first line is the number of case T (T<=10). 
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an, 
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms: 
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n) 
1 k p; the kth number of the sequence has been change to p. (1<=k<=n) 
You can assume that all the numbers before and after the replacement are no larger than 1 million. 
OutputFor each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.Sample Input

1
6
1 2 4 5 6 3
3
0 2 5
1 3 7
0 2 5

Sample Output

240
420

题意:输入n个数字,m次查询,每次查询三个数 a b c ,a=0时求b~c的乘积 a=1时将下标b的值修改为c
技术分享图片
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn = 50000+10;
const int INF = 0x3f3f3f3f;
const int Mod = 1000000007;
struct node
{
    int l,r;
    ll sum;
} tree[maxn<<2];
void pushup(int rt)
{
    tree[rt].sum=(tree[rt<<1].sum*tree[rt<<1|1].sum)%Mod;
}
void build(int l,int r,int rt)
{
    tree[rt].l=l;
    tree[rt].r=r;
    if(l==r)
    {
        scanf("%lld",&tree[rt].sum);
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void updata(int rt,int pos, ll c)
{
    if(tree[rt].l==tree[rt].r)
    {
        tree[rt].sum=c;
        return ;
    }
    int m=(tree[rt].l+tree[rt].r)>>1;
    if(pos<=m)
        updata(rt<<1,pos,c);
    else
        updata(rt<<1|1,pos,c);
    pushup(rt);

}
ll query(int l,int r,int rt)
{
    if(tree[rt].l>=l&&tree[rt].r<=r)
    {
        return tree[rt].sum;
    }
    ll ans=1;
    int m=(tree[rt].l+tree[rt].r)>>1;
    if(l<=m)
        ans=ans*query(l,r,rt<<1)%Mod;
    if(r>m)
        ans=ans*query(l,r,rt<<1|1)%Mod;
    return ans;

}
int main()
{
    int t,n,m;
    ll a,b,c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        build(1,n,1);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%lld %lld %lld",&a,&b,&c);
            if(a)
            {
                updata(1,b,c);
            }
            else
                printf("%I64d\n",query(b,c,1));
        }
    }
}
View Code

 

Multiply game HDU-3074

标签:can   multi   its   hang   name   use   play   efi   pos   

原文地址:https://www.cnblogs.com/MengX/p/9265512.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!