码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1004(map的使用)

时间:2018-07-11 19:56:23      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:ide   job   single   let   print   iterator   names   for   each   

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1004

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 143275    Accepted Submission(s): 56670


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 

 

Sample Output
red
pink
 

 

Author
WU, Jiazhi
 
 
题目意思:
找颜色单词出现得最多的那个单词
分析:
map的用法
很方便呀
原来都没有怎么用过
第一次用
开心
好用
code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    while(cin>>n,n)
    {
        map<string,int> mm;
        map <string,int>::iterator it;
        string ch;
        for(int i=0;i<n;i++)
        {
            cin>>ch;
            mm[ch]++;
        }
        int sum=0;
        string str;
        for(it=mm.begin();it!=mm.end();it++)
        {
           if(it->second>sum)
           {
               sum=it->second;
               str=it->first;
           }
        }
        cout<<str<<endl;
    }
    return 0;
}

 

HDU 1004(map的使用)

标签:ide   job   single   let   print   iterator   names   for   each   

原文地址:https://www.cnblogs.com/yinbiao/p/9295827.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!