码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2386 Lake Counting

时间:2018-07-11 22:52:16      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:man   sam   put   次数   div   void   namespace   and   %s   

Due to recent rains, water has pooled in various places in Farmer John‘s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W‘) or dry land (‘.‘). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John‘s field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John‘s field. Each character is either ‘W‘ or ‘.‘. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John‘s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
 
分析:注意水潭八个方向都是连通的,在主函数中对每个点进行dfs遍历,使用dfs遍历访问后做标记之后不再访问,主函数中dfs调用的次数即水池的个数
代码:
#include<iostream>
#include<cstdio>
using namespace std;
const int N = 105;
char mp[N][N];
int n, m;
void dfs(int x, int y) {
    mp[x][y] = .;
    for(int i = -1; i <= 1 ; i++) {
        for(int j = -1; j <= 1; j++) {
            int nx = x + i, ny = y + j;
            if(nx >= 0 && nx < n && ny >= 0 && ny < m && mp[nx][ny] == W) {
                dfs(nx, ny);
            }
        }
    }
}
int main() {
    scanf("%d%d", &n, &m);
    for(int i = 0; i < n; i++) scanf("%s", mp[i]);
    int count = 0;
    for(int i = 0; i < n; i++) {
        for(int j = 0; j < m; j++) {
            if(mp[i][j] == W) {
                dfs(i, j);
                count++;
            }
        }
    }
    printf("%d\n", count);
    return 0;
}

POJ 2386 Lake Counting

标签:man   sam   put   次数   div   void   namespace   and   %s   

原文地址:https://www.cnblogs.com/kindleheart/p/9296865.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!