码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1019 (多个数的最小公倍数)

时间:2018-07-15 14:57:12      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:意思   printf   mod   several   i++   cat   line   ast   int   

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1019

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61592    Accepted Submission(s): 23486


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

 

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
 

 

Sample Output
105 10296
 

 

Source
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1021 1061 1049 1108 1020 
 
题目意思:
求n个数的最小公倍数
直接暴力即可:暴力规则:求第一个和第二个元素的最小公倍数,然后拿求得的最小公倍数和第三个元素求最小公倍数,继续下去,直到没有元素
小技巧:
通过最大公约数求最小公倍数的时候,先除再乘,避免溢出
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int gcd(int a,int b)
{
    if (b==0)
        return a;
    return gcd(b, a%b);
}
int main()
{
    //公式:a,b的最小公倍数等于a,b的乘积除以a,b的最大公约数
    //直接暴力即可
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int a=1,cnt=1;
        int x;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            cnt=a/gcd(a,x)*x;//先除后乘,避免溢出
            a=cnt;
        }
        printf("%d\n",a);
    }
    return 0;
}

 

 

HDU 1019 (多个数的最小公倍数)

标签:意思   printf   mod   several   i++   cat   line   ast   int   

原文地址:https://www.cnblogs.com/yinbiao/p/9313387.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!