码迷,mamicode.com
首页 > 其他好文 > 详细

Cat VS Dog HDU - 3829 (最大独立集 )

时间:2018-07-15 19:24:11      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:vector   ber   sea   ring   fine   problem   find   fir   tip   

 

Cat VS Dog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 4383    Accepted Submission(s): 1602


Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child‘s like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child‘s like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.
 


Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child‘s like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
 


Output
For each case, output a single integer: the maximum number of happy children.
 


Sample Input
1 1 2 C1 D1 D1 C1 1 2 4 C1 D1 C1 D1 C1 D2 D2 C1
 


Sample Output
1 3
Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.
 


Source
 


Recommend
xubiao   |   We have carefully selected several similar problems for you:  3828 3830 3831 3832 3835 

 

 

不能以猫狗为顶点    那样找到的是哪些动物会转移   以小孩为顶点  找出最大点独立集   以小孩总数p为左右点集的顶点个数,假设小孩a喜欢的动物是小孩b不喜欢的动物   就连一条边edge(a,b)

记录猫和狗的

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <map>
#define mem(a, b) memset(a, b, sizeof(a))
using namespace std;
const int maxn = 10010, INF = 0x7fffffff;
int line[600][600], used[maxn], girl[maxn];

int nx, ny, n, m, p, cnt;
bool find(int x)
{
    for(int j=1; j<=p; j++)
    {
        if(line[x][j] == 1 && used[j] == -1)
        {
            used[j] = 1;
            if(girl[j] == 0 || find(girl[j]))
            {
                girl[j] = x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(cin>> n >> m >> p)
    {
        int ret = 0;
        mem(line, 0);
        char str1[550][5], str2[550][5];
        for(int i=1; i<=p; i++)
        {
            cin>> str1[i] >> str2[i];
            for(int j=1; j<i; j++)
                if(strcmp(str1[i],str2[j]) == 0 || strcmp(str1[j], str2[i]) == 0)
                    line[i][j] = line[j][i] = 1;
        }
        mem(girl, 0);
        for(int i=1; i<=p; i++)
        {
            mem(used, -1);
            if(find(i))
                ret++;
        }
        cout<< p-ret/2 <<endl;


    }

    return 0;
}

 

Cat VS Dog HDU - 3829 (最大独立集 )

标签:vector   ber   sea   ring   fine   problem   find   fir   tip   

原文地址:https://www.cnblogs.com/WTSRUVF/p/9314095.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!