标签:process AMM ane dynamic BMI sum print its 问题
传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1024
Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35988 Accepted Submission(s): 12807
Problem Description
Now I think you have got an AC in Ignatius.L‘s "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).
But I`m lazy, I don‘t want to write a special-judge module, so you don‘t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8
Hint
Huge input, scanf and dynamic programming is recommended.
Author
JGShining(极光炫影)
分析:
m个子段的最大子段和
子段不重合
第一次写这个问题,还不是很懂
我是参考的大佬的博客:
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
#define max_v 1000010
#define INF 0x7fffffff//无穷大
#define MIN_SUM 0x80000000//无穷小
int a[max_v];
int now[max_v];//now[j-1]表示的是以j-1结尾的元素i个子段的数和
int pre[max_v];//pre[j-1]表示的是前j-1个元素中i-1个子段的数和
int main()
{
int n,m,maxx,i,j;
while(~scanf("%d %d",&m,&n))
{
for( i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
memset(now,0,sizeof(now));
memset(pre,0,sizeof(pre));
for(i=1;i<=m;i++)
{
maxx=-INF;
for(j=i;j<=n;j++)
{
now[j]=max(now[j-1]+a[j],pre[j-1]+a[j]);
pre[j-1]=maxx;//放在此处是为了实现pre[j-1]+a[j]中a[j]是一个独立的子段,那么此时就应该用的是i-1段
if(now[j]>maxx)
{
maxx=now[j];
}
}
}
printf("%d\n",maxx);
}
return 0;
}
HDU 1024 Max Sum Plus Plus(m个子段的最大子段和)
标签:process AMM ane dynamic BMI sum print its 问题
原文地址:https://www.cnblogs.com/yinbiao/p/9314528.html