标签:order input row def ble eof single ini sum
题目描述
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
输入
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
输出
Output the sum of the maximal sub-rectangle.
样例输入
4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
样例输出
15
分析:最大子矩阵和,动态规划在线处理即可。
#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#define range(i,a,b) for(int i=a;i<=b;++i)
#define LL long long
#define rerange(i,a,b) for(int i=a;i>=b;--i)
#define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
using namespace std;
int N,MAP[105][105];
void init(){
cin>>N;
range(i,1,N)
range(j,1,N){
cin>>MAP[i][j];
MAP[i][j]+=MAP[i-1][j];
}
}
void solve(){
int ans=0x80000000;
range(i,1,N)
range(j,i,N){
int sum=0;
range(k,1,N){
sum+=MAP[j][k]-MAP[i-1][k];
sum=sum<0?0:sum;
ans=max(sum,ans);
}
}
cout<<ans<<endl;
}
int main() {
init();
solve();
return 0;
}
View Code
To the Max
标签:order input row def ble eof single ini sum
原文地址:https://www.cnblogs.com/Rhythm-/p/9318453.html