码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2017 字符串统计

时间:2018-07-17 00:46:04      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:target   i++   return   F12   char s   std   har   f11   mes   

http://acm.hdu.edu.cn/showproblem.php?pid=2017

 

Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
 
Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
 
Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
 
Sample Input
2 asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf
 
Sample Output
6
9
 
代码:
#include <bits/stdc++.h>

using namespace std;

const int maxn=1e5+10;
char s[maxn];

int main()
{
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%s",s);
        int len=strlen(s);
        int cnt=0;
        for(int j=0;j<len;j++)
        {
            if(s[j]>=‘0‘&&s[j]<=‘9‘)
                cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}

  

 

HDU 2017 字符串统计

标签:target   i++   return   F12   char s   std   har   f11   mes   

原文地址:https://www.cnblogs.com/zlrrrr/p/9321140.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!