码迷,mamicode.com
首页 > 其他好文 > 详细

1071 Speech Patterns (25)

时间:2018-07-17 00:49:54      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:only   get   sample   std   namespace   avatar   cal   rate   print   

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker‘s identity, which is useful when validating, for example, whether it‘s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone‘s speech, can you find the person‘s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return ‘\n‘. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can? It can!"

Sample Output:

can 5

#include<iostream>
#include<string>
#include<map>
using namespace std;
bool check(char a) {
    if (a >= ‘0‘ && a <= ‘9‘) return true;
    if(a >= ‘a‘ && a <= ‘z‘) return true; 
    if (a >= ‘A‘ && a <= ‘Z‘) return true;
    return false;
}
int main() {
    string str;
    getline(cin, str); //直接用cin是不行滴!!
    map<string, int> mp;
    int i = 0;
    while(i < str.length()){
        string word;
        while (i < str.length() && check(str[i]) == true) {
            if (str[i] >= ‘A‘ && str[i] <= ‘Z‘) str[i] += 32;
            word += str[i];
            i++;
        }
        if (word != "") {  //注意要判空
            if (mp.find(word) == mp.end()) mp[word] = 1;
            else mp[word]++;
        }
        while (i < str.length() && check(str[i]) == false) {  //括号放错地方搞出来的惨案!!
            i++;
        }
    }
    int num = 0; 
    string mword;
    for (map<string, int>::iterator it = mp.begin(); it != mp.end(); it++) {
        if (it->second > num) {
            mword = it->first;
            num = it->second;
        }
    }
    cout << mword << " " << num << endl;
    return 0;
}

1071 Speech Patterns (25)

标签:only   get   sample   std   namespace   avatar   cal   rate   print   

原文地址:https://www.cnblogs.com/Yaxadu/p/9321194.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!