码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4571 Travel in time (Floyd+记忆化搜索)

时间:2014-10-01 22:57:41      阅读:265      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   java   for   strong   

Travel in time

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1853    Accepted Submission(s): 374


Problem Description
  Bob gets tired of playing games, leaves Alice, and travels to Changsha alone. Yuelu Mountain, Orange Island, Window of the World, the Provincial Museum etc...are scenic spots Bob wants to visit. However, his time is very limited, he can’t visit them all. 
  Assuming that there are N scenic spots in Changsha, Bob defines a satisfaction value Si to each spot. If he visits this spot, his total satisfaction value will plus Si. Bob hopes that within the limited time T, he can start at spot S, visit some spots selectively, and finally stop at spot E, so that the total satisfaction value can be as large as possible. It‘s obvious that visiting the spot will also cost some time, suppose that it takes Ci units of time to visit spot i ( 0 <= i < N ).
  Always remember, Bob can choose to pass by a spot without visiting it (including S and E), maybe he just want to walk shorter distance for saving time. 
  Bob also has a special need which is that he will only visit the spot whose satisfaction value is strictly larger than that of which he visited last time. For example, if he has visited a spot whose satisfaction value is 50, he would only visit spot whose satisfaction value is 51 or more then. The paths between the spots are bi-directional, of course.
 

Input
  The first line is an integer W, which is the number of testing cases, and the W sets of data are following.
  The first line of each test data contains five integers: N M T S E. N represents the number of spots, 1 < N < 100; M represents the number of paths, 0 < M < 1000; T represents the time limitation, 0 < T <= 300; S means the spot Bob starts from. E indicates the end spot. (0 <= S, E < N)
  The second line of the test data contains N integers Ci ( 0 <= Ci <= T ), which means the cost of time if Bob visits the spot i.
  The third line also has N integers, which means the satisfaction value Si that can be obtained by visiting the spot i ( 0 <= Si < 100 ).
  The next M lines, each line contains three integers u v L, means there is a bi-directional path between spot u and v and it takes L units of time to walk from u to v or from v to u. (0 <= u, v < N, 0 <= L <= T)
 

Output
  Output case number in the first line (formatted as the sample output).
  The second line contains an integer, which is the greatest satisfaction value.
If Bob can’t reach spot E in T units of time, you should output just a “0” (without quotation marks).
 

Sample Input
1 4 4 22 0 3 1 1 1 1 5 7 9 12 0 1 10 1 3 10 0 2 10 2 3 10
 

Sample Output
Case #1: 21
 

思路:把问题分解,先求出任意两点之间的最短路,然后从起点开始搜索,记录三个量对应的状态值:当前位置、上一个景点的满意度、剩余时间。

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define N 110
const int inf=0x3fffffff;
int T,n,m,t,s,e;
int f[N][N][N*3]; //dp[i][j][k]表示在第i个城市,前一个城市的满意度为j,还剩下k的时间
int g[N][N];
int c[N],w[N];
void Floyd()
{
    int i,j,k;
    for(k=0;k<n;k++)
    {
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                g[i][j]=min(g[i][j],g[i][k]+g[k][j]);
            }
        }
    }
}
int dfs(int u,int val,int t)
{
    if(f[u][val][t]!=-1)
        return f[u][val][t];
    if(t<g[u][e])
        return -inf;
    int tmp=0,i;
    for(i=0;i<n;i++)
    {
        if(w[i]<=val)
            continue;
        tmp=max(tmp,dfs(i,w[i],t-c[i]-g[u][i])+w[i]);
    }
    return f[u][val][t]=tmp;
}
int main()
{
    int i,j,u,v,d,cnt=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d%d",&n,&m,&t,&s,&e);
        for(i=0;i<n;i++)
            scanf("%d",&c[i]);
        for(i=0;i<n;i++)
            scanf("%d",&w[i]);
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                g[i][j]=(i==j?0:inf);
            }
        }
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&d);
            g[u][v]=g[v][u]=min(g[u][v],d);
        }
        Floyd();
        memset(f,-1,sizeof(f));
        printf("Case #%d:\n%d\n",cnt++,dfs(s,0,t));
    }
    return 0;
}





hdu 4571 Travel in time (Floyd+记忆化搜索)

标签:des   style   color   io   os   ar   java   for   strong   

原文地址:http://blog.csdn.net/u011721440/article/details/39720695

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!