码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3311 Hie with the Pie (状态压缩+最短路)

时间:2014-10-02 13:19:53      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   for   strong   sp   

Hie with the Pie
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4491   Accepted: 2376

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8


思路:先用Floyd求出任意两点之间的最短路,然后,可以用广搜求得答案,搜索中的每个点第一次到达用二进制位进行标记。

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
#define N 12
const int inf=0x3fffffff;
struct node
{
    int x,s,t;  //位置、状态、时间
    int cnt;    //访问地点数目
    friend bool operator<(node a,node b)
    {
        return a.t>b.t;
    }
};
int mark[N][1030];
int g[N][N];
int n,ans;
void Floyd()
{
    int i,j,k;
    for(k=0;k<=n;k++)
    {
        for(i=0;i<=n;i++)
        {
            for(j=0;j<=n;j++)
            {
                g[i][j]=min(g[i][j],g[i][k]+g[k][j]);
            }
        }
    }
}
void bfs(int u)
{
    int i;
    priority_queue<node >q;
    node cur,next;
    cur.x=u;
    cur.t=cur.s=cur.cnt=0;
    q.push(cur);
    mark[u][0]=0;
    q.push(cur);
    while(!q.empty())
    {
        cur=q.top();
        q.pop();
        for(i=0;i<=n;i++)
        {
            next.s=cur.s;
            next.t=cur.t;
            next.cnt=cur.cnt;
            next.x=i;
            next.t+=g[cur.x][i];
            if(i&&(next.s&(1<<(i-1)))==0)
            {
                next.s|=(1<<(i-1));
                next.cnt++;
            }
            if(next.t<mark[i][next.s])
            {
                mark[i][next.s]=next.t;
                if(next.cnt==n)
                {
                    ans=min(ans,next.t+g[i][0]);
                    continue;
                }
                q.push(next);
            }
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<=n;i++)
        {
            for(j=0;j<=n;j++)
            {
                scanf("%d",&g[i][j]);
            }
        }
        Floyd();
        for(i=0;i<=n;i++)
        {
            for(j=0;j<(1<<n);j++)
                mark[i][j]=inf;
        }
        ans=inf;
        bfs(0);
        printf("%d\n",ans);
    }
    return 0;
}




poj 3311 Hie with the Pie (状态压缩+最短路)

标签:des   style   color   io   os   ar   for   strong   sp   

原文地址:http://blog.csdn.net/u011721440/article/details/39735869

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!