码迷,mamicode.com
首页 > 其他好文 > 详细

1007: 童年生活二三事

时间:2014-10-02 16:51:43      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   os   ar   for   数据   sp   

台州acm:1007: 童年生活二三事

Description

Redraiment小时候走路喜欢蹦蹦跳跳,他最喜欢在楼梯上跳来跳去。
但年幼的他一次只能走上一阶或者一下子蹦上两阶。
现在一共有N阶台阶,请你计算一下Redraiment从第0阶到第N阶共有几种走法。

Input

输入包括多组数据。
每组数据包括一行:N(1≤N≤40)。
输入以0结束。

Output

对应每个输入包括一个输出。
为redraiment到达第n阶不同走法的数量。

Sample Input

1
2
0

Sample Output

1
2

MyCode:
#include <iostream>

using namespace std;

int main( void )
{
	int num;
	int array[41 ]= { 0, 1, 2 };
	
	while(( cin>>num ), num!= 0 )
	{
		if( num== 1 || num== 2 )
		{
			cout<< array[ num ]<< endl;
		}
		else
		{
			int i;
			
			for( i= 3; i<= num; i++ )
			{
				array[ i ]= array[ i- 1 ]+array[ i- 2];
			}
			
			cout<< array[ num ]<< endl;
		}
	}
	
	return 0;
}


1007: 童年生活二三事

标签:des   style   http   io   os   ar   for   数据   sp   

原文地址:http://blog.csdn.net/mirrors_beyourself/article/details/39736491

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!