码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2533 Longest Ordered Subsequence(裸LIS)

时间:2018-07-21 22:52:45      阅读:273      评论:0      收藏:0      [点我收藏+]

标签:poj 2533   ++   ota   esc   others   plm   enc   ace   mis   

传送门:

http://poj.org/problem?id=2533

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 61731   Accepted: 27632

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion
 
分析:
完全裸露的LIS
 
code:
#include<stdio.h>
#define MAXN 1000
int dp[MAXN+10],a[MAXN+10];//a数组记录输入的序列
int main()
{
    int n,i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
       scanf("%d",&a[i]);
    dp[1]=1;
    for(i=2;i<=n;i++)
    {
        int temp=0;
        for(j=1;j<i;j++)
           if(a[i]>a[j])
              if(temp<dp[j])
                temp=dp[j];
        dp[i]=temp+1;
    }  
    int maxlen=0;
    for(i=1;i<=n;i++)
        if(maxlen<dp[i])
           maxlen=dp[i];
    printf("%d\n",maxlen);
    return 0;  
}

 

POJ 2533 Longest Ordered Subsequence(裸LIS)

标签:poj 2533   ++   ota   esc   others   plm   enc   ace   mis   

原文地址:https://www.cnblogs.com/yinbiao/p/9347993.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!