标签:revenue tab receive seq first width targe wan code
传送门:
http://poj.org/problem?id=3186
Treats for the Cows
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 7672 |
|
Accepted: 4059 |
Description
FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.
The treats are interesting for many reasons:
- The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
- Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
- The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
- Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?
The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N
Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:
Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).
FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
Source
分析:
题意:给出的一系列的数字,可以看成一个双向队列,每次只能从队首或者队尾出队,第n个出队就拿这个数乘以n,最后将和加起来,求最大和
思路:由里向外逆推区间
#include<stdio.h>
#include<string.h>
#include<memory>
using namespace std;
#define max_v 2005
int a[max_v];
int dp[max_v][max_v];
int main()
{
/*
dp[i][j]表示左边取了i个数,右边取了j个数
故
dp[i][j] = max(dp[i-1][j] + a[i]* (i+j), dp[i][j-1] + a[n-j+1]*(i+j));
注意当ij为0的边界判断即可。
*/
int n;
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
memset(dp,0,sizeof(dp));
int ans=0;
for(int i=0;i<=n;i++)
{
for(int j=0;j+i<=n;j++)
{
if(i==0&&j==0)
dp[i][j]=0;
else if(i==0)
dp[i][j]=dp[i][j-1]+a[n-j+1]*j;
else if(j==0)
dp[i][j]=dp[i-1][j]+a[i]*i;
else
dp[i][j]=max(dp[i-1][j]+a[i]*(i+j),dp[i][j-1]+a[n-j+1]*(i+j));
}
ans=max(ans,dp[i][n-i]);
}
printf("%d\n",ans);
}
return 0;
}
POJ 3186 Treats for the Cows(区间dp)
标签:revenue tab receive seq first width targe wan code
原文地址:https://www.cnblogs.com/yinbiao/p/9348004.html