码迷,mamicode.com
首页 > 其他好文 > 详细

10474 - Where is the Marble?(模拟)

时间:2018-07-23 12:41:32      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:can   com   scribe   was   cert   pre   ret   dex   tar   

传送门:

UVa10474 - Where is the Marble?

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to ?nd the ?rst marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some ?xed number of trials the game ends and the player with maximum points wins. Today it’s your chance to play as Raju. Being the smart kid, you’d be taking the favor of a computer. But don’t underestimate Meena, she had written a program to keep track how much time you’re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.
Input
There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative. Input is terminated by a test case where N = 0 and Q = 0.
Output
For each test case output the serial number of the case. For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two di?erent formats are described below: ? ‘x found at y’, if the ?rst marble with number x was found at position y. Positions are numbered 1,2,...,N. ? ‘x not found’, if the marble with number x is not present. Look at the output for sample input for details.
Sample Input
4 1 2 3 5 1 5 5 2 1 3 3 3 1 2 3 0 0
Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

 

分析:

 

现有N个大理石,每个大理石上写了一个非负整数。首先把各数从小到大排序,然后回答Q个问题。每个问题问是否有一个大理石写着某个整数x,如果是,还要回答哪个大理石上写着x。排序后的大理石从左到右编号为1~N

code:

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
int main()
{
    int n,q,k=1;
    while(cin>>n>>q)
    {
        //n个大理石 q的问题 x猜测数字
        if(n==0&&q==0)
            break;
        printf("CASE# %d:\n",k++);
        int a[n];
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        int x;
        sort(a,a+n);//排序
        while(q--)
        {
            cin>>x;
            int i=lower_bound(a,a+n,x)-a;//二分查找,查找大于或等于x的第一个位置
            if(a[i]==x)
            {
                printf("%d found at %d\n",x,i+1);
            }else
            {
                printf("%d not found\n",x);
            }
        }
    }
    return 0;
}

 

10474 - Where is the Marble?(模拟)

标签:can   com   scribe   was   cert   pre   ret   dex   tar   

原文地址:https://www.cnblogs.com/yinbiao/p/9353713.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!