码迷,mamicode.com
首页 > 其他好文 > 详细

Pat(Advanced Level)Practice--1044(Shopping in Mars)

时间:2014-05-13 14:33:08      阅读:437      评论:0      收藏:0      [点我收藏+]

标签:advance pat   基础题   

Pat1044代码

题目描述:

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5

未经过优化的代码,有两个case超时;
#include<cstdio>
#include<vector>
#include<algorithm>
#define MAX 100005

using namespace std;

typedef struct Pair
{
	int begin;
	int end;
	int sum;
}Pair;

int main(int argc,char *argv[])
{
	int n,m;
	int i,j;
	int Diamonds[MAX];
	int sum,min=0xFFFFFFF;
	int flag=0;
	int begin,end;
	vector<Pair> v;
	scanf("%d%d",&n,&m);
	for(i=1;i<=n;i++)
		scanf("%d",&Diamonds[i]);
	for(i=1;i<=n;i++)
	{
		sum=0;
	  	begin=i;
		for(j=i;j<=n;j++)
		{
			sum+=Diamonds[j];
			if(sum>m)
			{
				if(sum<min)
					min=sum;
				end=j;
				Pair temp;
				temp.begin=begin;
				temp.end=end;
				temp.sum=sum;
				v.push_back(temp);
				break;
			}
			if(sum==m)
			{
				flag=1;
				end=j;
				printf("%d-%d\n",begin,end);
				break;
			}
		}
	}
	if(!flag)
	{
		for(i=0;i<v.size();i++)
		{
			if(v[i].sum==min)
				printf("%d-%d\n",v[i].begin,v[i].end);
		}
	}

	return 0;
}

AC代码:经过小小的优化
#include<cstdio>
#include<vector>
#include<algorithm>
#define MAX 100005

using namespace std;

typedef struct Pair
{
	int begin;
	int end;
	int sum;
}Pair;

int Diamonds[MAX];
int start,finish;
int valuesum;

int main(int argc,char *argv[])
{
	int n,m;
	int i,j;
	int min=0xFFFFFFF;
	int flag=0;
	int FindPair=0;
	vector<Pair> v;
	scanf("%d%d",&n,&m);
	for(i=1;i<=n;i++)
		scanf("%d",&Diamonds[i]);
	for(i=1;i<=n;i++)
	{
		if(flag==1)//找到一个等于m的组合,那么下次没有必要从i开始进行加
		{          // 操作,可以从end+1开始,只需将sum的值减去Diamonds[i]
			valuesum=valuesum-Diamonds[start];
			start=finish+1;
			flag=0;
		}
		else
		{
			start=i;
			valuesum=0;
		}
		for(j=start;j<=n;j++)
		{
			valuesum+=Diamonds[j];
			if(valuesum>=m)
			{
				break;
			}
		}
		if(j>n)//很重要的一个剪枝操作,少了此步骤会有两个case超时
			break;//此时j已到达末尾仍然没有符合条件的值说明没有必要进行下
		if(valuesum>m)//去了,因为随着i++操作则valuesum的值会更小,更不存在
		{	            // 符合条件的组合
			if(valuesum<min)
				min=valuesum;//保存大于m的最小的和
			finish=j;
			Pair temp;
			temp.begin=start;
			temp.end=finish;
			temp.sum=valuesum;
			v.push_back(temp);
		}
		if(valuesum==m)
		{
			flag=1;
			FindPair=1;
			finish=j;
			printf("%d-%d\n",start,finish);
		}
	}
	if(!FindPair)
	{
		for(i=0;i<v.size();i++)
		{
			if(v[i].sum==min)
				printf("%d-%d\n",v[i].begin,v[i].end);
		}
	}

	return 0;
}

Pat(Advanced Level)Practice--1044(Shopping in Mars),布布扣,bubuko.com

Pat(Advanced Level)Practice--1044(Shopping in Mars)

标签:advance pat   基础题   

原文地址:http://blog.csdn.net/cstopcoder/article/details/25652543

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!