码迷,mamicode.com
首页 > 其他好文 > 详细

Bellman算法PKU 3259

时间:2014-10-03 12:01:04      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:最短路

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 31593   Accepted: 11497

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ‘s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, andW (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
//#include <map>
using namespace std;

const int VM = 520;
const int EM = 5020;
const int INF = 0x3f3f3f3f;
//const int INF = 0x3f3f3f3f;

struct Edge{
    int u,v;
    int w;
}edge[EM<<1];

int N,M,W,cnt,dis[VM];

void addage(int cu,int cv,int cw){
    edge[cnt].u = cu;
    edge[cnt].v = cv;
    edge[cnt].w = cw;
    cnt++;
}

int Bellman(){
    int i,j,flag;
    for(i=0;i<N;i++){
        dis[i] = INF;
    }
    for(i=1;i<N;i++){
        flag = 1;
        for(j=0;j<cnt;j++){
            if(dis[edge[j].u] > dis[edge[j].v]+edge[j].w){
                dis[edge[j].u] = dis[edge[j].v]+edge[j].w;
                flag = 0;
            }
        }
        if(flag){
            break;
        }
    }
    for(i=0;i<cnt;i++){
        if(dis[edge[i].u] > dis[edge[i].v]+edge[i].w){
            return 1;
        }
    }

    return 0;
}

int main(){
    int t;
    int i;

    while(~scanf("%d",&t)){
        while(t--){
            scanf("%d%d%d",&N,&M,&W);
            cnt = 0;
            int u,v,w;
            for(i=0;i<M;i++){
                scanf("%d%d%d",&u,&v,&w);
                addage(u,v,w);
                addage(v,u,w);
            }
            for(i=0;i<W;i++){
                scanf("%d%d%d",&u,&v,&w);
                addage(u,v,-w);
            }
            if(Bellman()){
                printf("YES\n");
            }
            else{
                printf("NO\n");
            }
        }
    }

    return 0;
}


Bellman算法PKU 3259

标签:最短路

原文地址:http://blog.csdn.net/zcr_7/article/details/39753993

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!