码迷,mamicode.com
首页 > 其他好文 > 详细

1001 A+B Format (20)

时间:2018-07-29 11:55:14      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:++   scan   pair   should   bsp   color   cst   pre   输出   

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991
//先求和再将和存储到数组中,倒叙三位一组输出 
#include<cstdio>
int num[10];
int main(){
    int a,b;
    scanf("%d%d",&a,&b);
    int sum = a + b;
    if(sum < 0){
        printf("-");
        sum = -sum;
    }
    int len = 0; 
    if(sum == 0) num[len++] = 0; //可以用do while()循环就不用对len=0进行特殊处理 
    while(sum){
        num[len++] = sum % 10;
        sum /= 10;
    }
    for(int i = len - 1; i >= 0; i--){
        printf("%d",num[i]);
        if(i > 0 && i % 3 == 0) printf(",");
    }
    return 0;
}
//printf输出格式中,%3d输出三位整数,位数不足高位补空格 %03位数不足补0 
#include<cstdio>
int num[10];
int main(){
    int a,b;
    scanf("%d%d",&a,&b);
    int sum = a + b;
    if(sum < 0){
        printf("-");
        sum = -sum;
    }
   if(sum >= 1000000)  printf("%d,%03d,%03d",sum/1000000,sum%1000000/1000,sum%1000); //第二个数要mod1000000 且等号不能少
   else if(sum > 1000) printf("%d,%03d",sum/1000,sum%1000); //1000通过 
   else {
       printf("%d",sum);
   }
    return 0;
}

 

1001 A+B Format (20)

标签:++   scan   pair   should   bsp   color   cst   pre   输出   

原文地址:https://www.cnblogs.com/wanghao-boke/p/9384611.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!