码迷,mamicode.com
首页 > 其他好文 > 详细

1002 A+B for Polynomials (25)

时间:2018-07-29 13:11:25      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:return   ima   ati   sed   extra   sum   orm   info   sam   

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
#include<cstdio>
const int maxn = 1010;
double p[maxn] = {};
int main(){
    int k,n;
    double a;
    scanf("%d",&k);
    for(int i = 0; i < k; i++){
        scanf("%d %lf",&n,&a);
        p[n] += a;
    }
    scanf("%d",&k);
    for(int i = 0; i < k; i++){
        scanf("%d %lf",&n,&a);
        p[n] += a;
    }
    int count = 0;
    for(int i = 0; i < maxn; i++){
        if(p[i] != 0) count++;
    }
    printf("%d",count);
    for(int i = maxn - 1; i >= 0; i--){
        if(p[i] != 0) printf(" %d %.1f",i,p[i]);
    }
    return 0;
}

 

1002 A+B for Polynomials (25)

标签:return   ima   ati   sed   extra   sum   orm   info   sam   

原文地址:https://www.cnblogs.com/wanghao-boke/p/9384873.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!