码迷,mamicode.com
首页 > 其他好文 > 详细

poj2406Power Strings

时间:2018-07-31 17:23:53      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:const   链接   printf   names   namespace   each   efi   opened   scanf   

 链接:http://poj.org/problem?id=2406

 

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
     

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

技术分享图片

技术分享图片
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int M = 1e6 + 5;

char c[M];
int len, fail[M];

void init(){
    fail[0] = -1;
    int i = 0, j = -1;
    while(i < len){
        if(j == -1 || c[i] == c[j]) i++, j++, fail[i] = j;
        else j = fail[j];
        
    }
}

int main(){
    while(scanf("%s", c)){
        if(c[0] == .)break;
        len = strlen(c);
        init();
        if(len % (len - fail[len]))puts("1");
        else printf("%d\n", len / ( len - fail[len]));
    }
    
    
}
View Code

 

poj2406Power Strings

标签:const   链接   printf   names   namespace   each   efi   opened   scanf   

原文地址:https://www.cnblogs.com/EdSheeran/p/9396148.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!