码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1160 Post Office (区间动态规划)

时间:2014-10-04 00:11:35      阅读:392      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   for   strong   sp   

Post Office
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15966   Accepted: 8671

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

思路:

sum[i][j]:在第i个村庄和第j个村庄之间建一个邮局的最短距离;

【1,3】邮局建在第2个村庄;

【1,4】邮局建在2、3距离一样;

【1,5】sum[1][5]=sum[1][4]+村庄5到3的距离;

即:sum[i][j]=sum[i][j-1]+x[j]-x[(i+j)/2];

dp[i][j]:在前i个村庄中建立j个邮局的最小距离;

dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]) ;即在[1,K]村庄建立j-1个邮局,在[k+1,i]村庄建立一个邮局


#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define N 305
const int inf=0x3fffffff;
int dp[N][35]; //在前i个村庄中建立j个邮局的最小耗费
int sum[N][N];//sum[i][j]:第i个村庄到第j个村庄建一个邮局的最短距离
int x[N]; //村庄位置
int main()
{
    int v,p,i,j,k;
    while(scanf("%d%d",&v,&p)!=-1)
    {
        for(i=1;i<=v;i++)
            scanf("%d",&x[i]);
        memset(sum,0,sizeof(sum));
        for(i=1;i<=v;i++)
        {
            for(j=i+1;j<=v;j++)
            {
                sum[i][j]=sum[i][j-1]+x[j]-x[(i+j)/2];
            }
        }
        for(i=1;i<=v;i++)
        {
            dp[i][i]=0; //一个村庄一个邮局距离为零
            dp[i][1]=sum[1][i]; 前i个村庄建立一个邮局
        }
        for(j=2;j<=p;j++)
        {
            for(i=j+1;i<=v;i++)
            {
                dp[i][j]=inf;
                for(k=j-1;k<i;k++)
                {
                    dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);
                }
            }
        }
        printf("%d\n",dp[v][p]);
    }
    return 0;
}


poj 1160 Post Office (区间动态规划)

标签:des   style   color   io   os   ar   for   strong   sp   

原文地址:http://blog.csdn.net/u011721440/article/details/39759605

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!