码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2669 Romantic(扩展欧几里德)

时间:2014-10-03 22:48:35      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:扩展   gcd   hdu   扩展欧几里德   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2669


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

bubuko.com,布布扣 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input
77 51 10 44 34 79
 

Sample Output
2 -3 sorry 7 -3
 

Author
yifenfei
 

Source

PS:

扩展欧几里德模板题;

附:扩展欧几里德讲解:http://blog.csdn.net/u012860063/article/details/39760003

代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
typedef __int64 LL;

LL exgcd(LL a,LL b,LL &x,LL &y)
{
    if(b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    else
    {
        LL r = exgcd(b,a%b,x,y);
        LL t = x;
        x = y;
        y = t-a/b*y;
        return r;
    }
}

int main()
{
    LL a,b,x,y;
    while(scanf("%I64d%I64d",&a,&b)!=EOF)
    {
        LL d = exgcd(a,b,x,y);
        if(1%d)//不能整除
            printf("sorry\n");
        else
        {
            while(x<0)
                x+=b,y-=a;
            printf("%I64d %I64d\n",x,y);
        }
    }
    return 0;
}


HDU 2669 Romantic(扩展欧几里德)

标签:扩展   gcd   hdu   扩展欧几里德   

原文地址:http://blog.csdn.net/u012860063/article/details/39759941

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!