码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2123 An easy problem

时间:2018-08-03 01:15:55      阅读:272      评论:0      收藏:0      [点我收藏+]

标签:cpp   make   scan   hdu   can   des   integer   line   tle   

http://acm.hdu.edu.cn/showproblem.php?pid=2123

 

Problem Description
In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.
 
Input
The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
 
Output
For each test case, print out the multiply table.
 
Sample Input
2
1
4
 
Sample Output
1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16

代码:

#include <bits/stdc++.h>
using namespace std;

int num[10][10];

int main() {
    int T;
    scanf("%d", &T);
    while(T --) {
        int x;
        scanf("%d", &x);

        for(int i = 1; i <= x; i ++) {
            for(int j = 1; j <= x; j ++)
                num[i][j] = i * j;
        }

        for(int i = 1; i <= x; i ++) {
            for(int j = 1; j <= x; j ++) {
                if(j != x)
                    printf("%d ", num[i][j]);
                else
                    printf("%d\n", num[i][j]);
            }
        }

    }
    return 0;
}

  

 

HDU 2123 An easy problem

标签:cpp   make   scan   hdu   can   des   integer   line   tle   

原文地址:https://www.cnblogs.com/zlrrrr/p/9410872.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!