码迷,mamicode.com
首页 > 其他好文 > 详细

Boy or Girl

时间:2018-08-04 16:15:04      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:not   class   first   clu   细节   english   stream   eth   script   

Description


Those days, many boys use beautiful girls photos as avatars in forums. So it is pretty hard to tell the gender of a user at the first glance. Last year, our hero went to a forum and had a nice chat with a beauty (he thought so). After that they talked very often and eventually they became a couple in the network.

But yesterday, he came to see "her" in the real world and found out "she" is actually a very strong man! Our hero is very sad and he is too tired to love again now. So he came up with a way to recognize users genders by their user names.

This is his method: if the number of distinct characters in ones user name is odd, then he is a male, otherwise she is a female. You are given the string that denotes the user name, please help our hero to determine the gender of this user by his method.

Input


Every line contains a non-empty string, that contains only lowercase English letters — the user name. This string contains at most 100 letters.

Output


If it is a female by our heros method, print "CHAT WITH HER!" (without the quotes), otherwise, print "IGNORE HIM!" (without the quotes).

Sample Input

wjmzbmr
xiaodao
sevenkplus

Sample Output

CHAT WITH HER!
IGNORE HIM!
CHAT WITH HER!
#include<cstdio>
#include<vector>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
  
int main()
{
   char a[101];
   int len ,i,ans;
   while(scanf("%s",a)!=EOF)  scanf不吸收空格
   {
       ans=1;  //注意细节
       len=strlen(a);    
       sort(a,a+len);    //直接对字符串排序
       for(i=0;i<len-1;i++)  //注意细节,如果是i+1的话注意i的边界只能到len-1
       {
            if(a[i]!=a[i+1])
                ans++;
       }
       if(ans%2==0)
           printf("CHAT WITH HER!\n");
       else
           printf("IGNORE HIM!\n");
   }
    return 0;
}

思路:将字母排序,两两进行比较看看相不相等

Boy or Girl

标签:not   class   first   clu   细节   english   stream   eth   script   

原文地址:https://www.cnblogs.com/liufei-/p/9418865.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!